找DLL电脑论坛

 找回密码
 立即注册
查看: 56|回复: 0

神奇九转指标主图源码

[复制链接]

427

主题

446

帖子

1914

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
1914
发表于 2021-4-24 20:36:11 | 显示全部楼层 |阅读模式
  1. {神奇九转}

  2. A1:=C>=REF(C,4);

  3. A:=C<REF(C,4);

  4. AA:=C<REF(C,4) AND REF(A1,1);

  5. T:=BARSLAST(AA)NODRAW;

  6. M:=(T=0 AND REFX(T=1 AND NOT(A),1)) OR (REFX(T=2 AND NOT(A),2)) OR (REFX(T=3 AND NOT(A),3)) OR (REFX(T=4 AND NOT(A),4)) OR (REFX(T=5 AND NOT(A),5))

  7. OR (REFX(T=6 AND NOT(A),6)) OR (REFX(T=7 AND NOT(A),7)) OR (REFX(T=8 AND NOT(A),8));

  8. M1:=T=1 AND REFX(T=2 AND NOT(A),1) OR (REFX(T=3 AND NOT(A),2)) OR (REFX(T=4 AND NOT(A),3)) OR (REFX(T=5 AND NOT(A),4)) OR (REFX(T=6 AND NOT(A),5))

  9. OR (REFX(T=7 AND NOT(A),6)) OR (REFX(T=8 AND NOT(A),7));

  10. M2:=T=2 AND REFX(T=3 AND NOT(A),1) OR (REFX(T=4 AND NOT(A),2)) OR (REFX(T=5 AND NOT(A),3)) OR (REFX(T=6 AND NOT(A),4)) OR (REFX(T=7 AND NOT(A),5)) OR (REFX(T=8 AND NOT(A),6));

  11. M3:=T=3 AND REFX(T=4 AND NOT(A),1)OR (REFX(T=5 AND NOT(A),2)) OR (REFX(T=6 AND NOT(A),3)) OR (REFX(T=7 AND NOT(A),4)) OR (REFX(T=8 AND NOT(A),5));

  12. M4:=T=4 AND REFX(T=5 AND NOT(A),1) OR (REFX(T=6 AND NOT(A),2)) OR (REFX(T=7 AND NOT(A),3)) OR (REFX(T=8 AND NOT(A),4));

  13. M5:=T=5 AND REFX(T=6 AND NOT(A),1) OR (REFX(T=7 AND NOT(A),2)) OR (REFX(T=8 AND NOT(A),3));

  14. M6:=T=6 AND REFX(T=7 AND NOT(A),1) OR (REFX(T=8 AND NOT(A),2));

  15. M7:=T=7 AND REFX(T=8 AND NOT(A),1);

  16. N:=T=1 AND REF(T=0 AND AA,1) AND A;

  17. N1:=T=2 AND REF(N,1) AND A;

  18. N2:=T=3 AND REF(N1,1) AND A;

  19. N3:=T=4 AND REF(N2,1) AND A;

  20. N4:=T=5 AND REF(N3,1) AND A;

  21. N5:=T=6 AND REF(N4,1) AND A;

  22. N6:=T=7 AND REF(N5,1) AND A;

  23. N7:=T=8 AND REF(N6,1) AND A;

  24. DRAWTEXT(T=0,H*1.02,'1')COLORGREEN;

  25. DRAWTEXT(N,H*1.02,'2')COLORGREEN;

  26. DRAWTEXT(N1,H*1.02,'3')COLORGREEN;

  27. DRAWTEXT(N2,H*1.02,'4')COLORGREEN;

  28. DRAWTEXT(N3,H*1.02,'5')COLORGREEN;

  29. DRAWTEXT(N4,H*1.02,'6')COLORGREEN;

  30. DRAWTEXT(N5,H*1.02,'7')COLORGREEN;

  31. DRAWTEXT(N6,H*1.02,'8')COLORGREEN;

  32. DRAWTEXT(N7,H*1.02,'9')COLORGREEN;

  33. DRAWICON(N7,H*1.04,1)COLORGREEN;

  34. DRAWTEXT(M,H*1.02,'1')COLORBLACK;

  35. DRAWTEXT(M1,H*1.02,'2')COLORBLACK;

  36. DRAWTEXT(M2,H*1.02,'3')COLORBLACK;

  37. DRAWTEXT(M3,H*1.02,'4')COLORBLACK;

  38. DRAWTEXT(M4,H*1.02,'5')COLORBLACK;

  39. DRAWTEXT(M5,H*1.02,'6')COLORBLACK;

  40. DRAWTEXT(M6,H*1.02,'7')COLORBLACK;

  41. DRAWTEXT(M7,H*1.02,'8')COLORBLACK;

  42. B1:=C<=REF(C,4);

  43. B:=C>REF(C,4);

  44. BB:=C>REF(C,4) AND REF(B1,1);

  45. T1:=BARSLAST(BB)NODRAW;

  46. M111:=(T1=0 AND REFX(T1=1 AND NOT(B),1)) OR (REFX(T1=2 AND NOT(B),2)) OR (REFX(T1=3 AND NOT(B),3)) OR (REFX(T1=4 AND NOT(B),4)) OR (REFX(T1=5 AND NOT(B),5))

  47. OR (REFX(T1=6 AND NOT(B),6)) OR (REFX(T1=7 AND NOT(B),7)) OR (REFX(T1=8 AND NOT(B),8));

  48. M11:=T1=1 AND REFX(T1=2 AND NOT(B),1) OR (REFX(T1=3 AND NOT(B),2)) OR (REFX(T1=4 AND NOT(B),3)) OR (REFX(T1=5 AND NOT(B),4)) OR (REFX(T1=6 AND NOT(B),5))

  49. OR (REFX(T1=7 AND NOT(B),6)) OR (REFX(T1=8 AND NOT(B),7));

  50. M22:=T1=2 AND REFX(T1=3 AND NOT(B),1) OR (REFX(T1=4 AND NOT(B),2)) OR (REFX(T1=5 AND NOT(B),3)) OR (REFX(T1=6 AND NOT(B),4)) OR (REFX(T1=7 AND NOT(B),5)) OR (REFX(T1=8 AND NOT(B),6));

  51. M33:=T1=3 AND REFX(T1=4 AND NOT(B),1)OR (REFX(T1=5 AND NOT(B),2)) OR (REFX(T1=6 AND NOT(B),3)) OR (REFX(T1=7 AND NOT(B),4)) OR (REFX(T1=8 AND NOT(B),5));

  52. M44:=T1=4 AND REFX(T1=5 AND NOT(B),1) OR (REFX(T1=6 AND NOT(B),2)) OR (REFX(T1=7 AND NOT(B),7)) OR (REFX(T1=8 AND NOT(B),4));

  53. M55:=T1=5 AND REFX(T1=6 AND NOT(B),1) OR (REFX(T1=7 AND NOT(B),2)) OR (REFX(T1=8 AND NOT(B),3));

  54. M66:=T1=6 AND REFX(T1=7 AND NOT(B),1) OR (REFX(T1=8 AND NOT(B),2));

  55. M77:=T1=7 AND REFX(T1=8 AND NOT(B),1);

  56. N111:=T1=1 AND REF(T1=0 AND BB,1) AND B;

  57. N11:=T1=2 AND REF(N111,1) AND B;

  58. N22:=T1=3 AND REF(N11,1) AND B;

  59. N33:=T1=4 AND REF(N22,1) AND B;

  60. N44:=T1=5 AND REF(N33,1) AND B;

  61. N55:=T1=6 AND REF(N44,1) AND B;

  62. N66:=T1=7 AND REF(N55,1) AND B;

  63. N77:=T1=8 AND REF(N66,1) AND B;

  64. DRAWTEXT(T1=0,H*1.02,'1')COLOR9900CC;

  65. DRAWTEXT(N111,H*1.02,'2')COLOR9900CC;

  66. DRAWTEXT(N11,H*1.02,'3')COLOR9900CC;

  67. DRAWTEXT(N22,H*1.02,'4')COLOR9900CC;

  68. DRAWTEXT(N33,H*1.02,'5')COLOR9900CC;

  69. DRAWTEXT(N44,H*1.02,'6')COLOR9900CC;

  70. DRAWTEXT(N55,H*1.02,'7')COLOR9900CC;

  71. DRAWTEXT(N66,H*1.02,'8')COLOR9900CC;

  72. DRAWTEXT(N77,H*1.02,'9')COLOR9900CC;

  73. DRAWICON(N77,H*1.04,2);

  74. DRAWTEXT(M111,H*1.02,'1')COLORBLACK;

  75. DRAWTEXT(M11,H*1.02,'2')COLORBLACK;

  76. DRAWTEXT(M22,H*1.02,'3')COLORBLACK;

  77. DRAWTEXT(M33,H*1.02,'4')COLORBLACK;

  78. DRAWTEXT(M44,H*1.02,'5')COLORBLACK;

  79. DRAWTEXT(M55,H*1.02,'6')COLORBLACK;

  80. DRAWTEXT(M66,H*1.02,'7')COLORBLACK;

  81. DRAWTEXT(M77,H*1.02,'8')COLORBLACK;
复制代码

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|小黑屋|找DLL下载站

GMT+8, 2021-5-13 19:22 , Processed in 5.953163 second(s), 22 queries .

快速回复 返回顶部 返回列表